Quickstart

Hyperview is a next generation, cloud-based Data Center Infrastructure Management (DCIM) software designed to provide a superior monitoring, capacity planning, and administration experience. This document assumes the user is a first-time Hyperview user who will administer the product. The following high-level diagram depicts the onboarding process from start to finish.

introduction_1

Note

You will receive an email link to complete setting up your Administrator account.

Prerequisites

Supported web browsers

You can run Hyperview on Google Chrome, Mozilla Firefox, or Microsoft Edge (Chromium).

Note

For security reasons, we recommend always updating to the latest stable version of your chosen browser.

Hardware and software requirements

You must install the Hyperview Data Collector on at least one server that is networked with your devices in order to run auto-discoveries (or discoveries, for short). You can install the Data Collector on a server running Windows Server 2016 (for production or testing purposes), Windows Server 2019 (for production or testing purposes), or Windows 10 (for testing only). The server must have a minimum of 2 CPU cores, 4 GB of RAM, and 20 GB of free space.

Note

For larger organizations we recommend having one or more Data Collector servers per data center. You cannot install multiple instances of the Data Collector on the same server.

Network requirements

You must grant the Data Collector access to the following network ports to be able to monitor and discover devices.

Protocol Ports Credential Requirements
SNMP 161, 162 Community string or user/pass
Modbus/TCP 502 Not required
BACnet IP 87808 or UDP Not required
IPMI 623 and 1900 User/password
SSH 22 User/password or user/key
WMI 135 User/password
VMware 883 User/password

Planning and setup

Gathering data

We recommend collecting the following information beforehand to streamline your Hyperview onboarding experience.

  • A list of intended users including their email addresses and what kind of Hyperview role they should have (Administrator, Data Center Manager, Power User, Read Only, or Reporting)
  • A list of web domains used by your company (for example, “yourcompany.com”)
  • A list of IP addresses or ranges for devices that you wish to include or exclude from Hyperview discovery scans
  • Physical addresses and background images (such as floor maps) for all your data center locations
  • A list of all your racks including their location, model, and manufacturer
  • A list of all your assets including their location, model, manufacturer, and serial number

Tip

You can download an asset bulk import template directly from Hyperview follows (go to Assets → Bulk Import → Download Template File → Assets).

Installing and configuring Data Collectors

Downloading the Data Collector

  1. Log in to your Hyperview instance as an Administrator.
  2. Go to Discoveries → Data Collectors → Download Data Collector.

The Data Collector zip file will be downloaded to your browser’s default download location. The filename will resemble “dataCollector-9999.zip”, where “9999” represents the version number.

Installing the Data Collector

  1. Extract the downloaded Data Collector zip file to a local folder.

  2. Browse to the folder and double-click “setup.exe”.

    dc_setup_file

    Tip

    Some security software (such as Microsoft Defender SmartScreen) or Windows features (such as UAC) may interrupt the installation. In such cases you will need to manually allow the Data Collector installer to run, typically via a “run anyway” or similar action.

  3. Depending on your environment, you might get prompted to install one or more of the following: .NET framework, Visual C++ runtime libraries, WinPcap. If you do, simply click Install and proceed to install the prerequisite software using default values.

    Note

    While installing WinPCap ensure the “Automatically start the WinPcap drive at boot time” option is selected.

  4. Click Next to start the Data Collector setup.

  5. Accept the license terms by selecting “I accept…”, then click Next.

  6. Choose a different installation folder or click Next to accept the default location.

    dc_install_3

  7. Click Install.

  8. Towards the end of the process, the Data Collector Configuration Tool will appear. You will need to provide details to register your data collector. Refer to the following section (“Registering the Data Collector”) for instructions.

    dc_install_9

  9. Click Finish to complete the installation.

Registering Data Collectors

Once you have installed the Data Collector, you need to register it with Hyperview using a unique registration token. The Data Collector Configuration Tool (which registers the Data Collector) is automatically triggered during the Data Collector installation.

You can also run the Data Collector Configuration Tool from C:\Program Files\Hyperview\Hyperview Data Collector\configurationTool\AgentConfigurer.exe, assuming you have installed the Data Collector at the default location.

To retrieve the registration token from Hyperview:

  1. Log in to your Hyperview instance as an Administrator.

  2. Go to Discoveries → Data Collectors → Add. The “Add Data Collector” modal will open.

  3. Click the file icon to copy the registration token.

    dc_install_8

  4. Click OK to close the modal.

To configure the Data Collector using the Data Collector Configuration Tool:

  1. Paste the registration token and enter your API hostname (for example, “yourcompany.hyperviewhq.com”). Leave all other values as default.
    • If you are using a custom BACnet device ID, select “Use Custom BACnet Server Device ID” and enter the custom device ID. (If you do not provide the custom device ID the device will still get discovered, but will be assigned a default ID.)
  2. Click Register.

To re-register a Data Collector, simply repeat the steps outlined in this section.

Verifying your Data Collector installation

If your Data Collector was set up correctly, the Services view in Windows (search for the “Services” app from the Windows search bar) will indicate that the Hyperview Data Collector and Hyperview SNMP Trap Listener services are running and set to start automatically, as seen below.

services

Note

To avoid potential errors please ensure the default SNMP Service in Windows is disabled.

Updating Data Collectors

To install the latest Data Collector, first uninstall the existing Data Collector, then proceed to install and register the new Data Collector as described above.

Retiring a Data Collector

You can retire a Data Collector to remove it from the system. You must specify a substitute Data Collector as part of the retirement process.

  1. Log in to your Hyperview instance as an Administrator.
  2. Go to Discoveries → Data Collectors.
  3. Click the Retire button for the intended Data Collector. The “Retire Data Collector” modal will open.
  4. Select the substitute Data Collector from the dropdown and click Save.

Note

Retiring a Data Collector is permanent and cannot be undone.


Setting up users

A user account in Hyperview corresponds to a real-world user. Individuals can have more than one user account to satisfy different job functions (for example, IT Manager and QA).

To administer users

  • Go to Account → Profile → use relevant links under User Administration.

user_mgmt_05

To create domains

A “domain” corresponds to a valid corporate domain.

  • Go to Domain → Add Domain → enter your domain, such as “yourcompany.com” → Add.

To add a user

Administrators have full application access and are not restricted by access control policies. The remaining roles (Data Center Manager, Power User, and Read Only) range from limited access to read-only access, depending on the scope of their work.

  • Go to Users → Add User → enter details → Add.

Creating locations

Locations in Hyperview are considered groups for containing assets. If a location is nested within another location, the nested location is referred to as a “child” location.

Adding a location

  1. Go to Assets → Add New → Select “Location”.
  2. Enter details. In the absence of a parent location, select “All”.
  3. Do either of the following:
    • Click Add → Add and Continue With New Values to start with blank fields for subsequent entries; or
    • Click Add → Add and Continue With Same Values to repeat the entered values (except for Name) for subsequent entries.

The location will now appear in the hierarchy (Assets → Overview → click “Hierarchy” in the drop-down) under its parent location.

Tip

You can also create a location from the right-click menu in the hierarchy (right-click on parent location → Add New Location). Note that with this approach you can click on Add to simply add the location, in addition to being able to add and continue with new or same values (as described in step 3 above).

Adding a location layout

Location layouts in Hyperview let you visually interact with a given location. These can include (but aren’t limited to) floor plans, room images, and building pictures.

  1. Click on the location in the hierarchy. The location dashboard will open.
  2. Click Layout tab → Edit → Tools → Add Background Image.
  3. Select the intended background image.
  4. Click Edit → Tools → add one of the following grid options:
    • Grid - Auto Generate
    • Grid - Rectangle
    • Grid - Polygon

The location layout will be added.

Adding a location map

You can add a location map to get a top-down Google Maps view of your location and its children.

Note

This is only applicable if there is at least one child location.

  1. Click on a child location in the hierarchy. The location dashboard will open.
  2. Click Information tab → Properties.
  3. Under “Contact” enter a value for the Address field.
  4. Select the parent location in the hierarchy → Layout tab → Edit.
  5. Select Mode → Map Mode → Save.

The location map will be saved.


Adding racks

Racks (and shelves within them) contain assets.

Adding a rack

  1. Go to Assets → Add New → select “Rack” → enter details.
  2. Do either of the following:
    • Click Add → Add and Continue With New Values to start with blank fields for subsequent entries; or
    • Click Add → Add and Continue With Same Values to repeat the entered values (except for Name) for subsequent entries.

The rack will now appear in the hierarchy (Assets → Overview → click “Hierarchy” in the drop-down) under its parent location.

Tip

You can also create a rack from the right-click menu in the hierarchy (right-click on parent location → Add New Asset). Note that with this approach you can click on Add to simply add the location, in addition to being able to add and continue with new or same values (as described in step 3 above).

Adding a rack to a location layout

You can surface a rack on an existing location layout to visually interact with it.

Note

The target location must have a layout and a grid.

  1. Browse to the target location in hierarchy.
  2. Click Layout tab → Edit.
  3. Drag the rack from the hierarchy to a grid tile in the layout.

The rack appear in the location layout.

Adding a shelf to a rack

You can add shelves to racks for fine-grained asset placement. Zero U and unplaced assets will appear in their own category in the rack layout view.

  1. Browse to the rack in the hierarchy.
  2. Click Layout tab → Add Shelf.
  3. Enter details and save.

The shelf will get added.


Adding assets

The term assets refers to devices and objects at a given location. These include (but are not limited to) IT equipment, facility infrastructure, containers, virtual machines, blades, and so on.

Note

In addition to the methods described in this section, assets can be discovered and added automatically (see Adding discoveries).

Bulk importing assets

  1. Go to Assets → Bulk Import → Download Template File → Assets. A CSV template for bulk importing assets will be downloaded to your browser’s default download directory.

  2. Update the template with asset details for the target location. Rename and save the file to a different folder, if needed.

    Note

    The import process is per-location.

  3. Click Select Location and File and specify values. Use “Assets” in the Template dropdown.

  4. Click Select to upload the file.

  5. Once the file is uploaded, verify the displayed list of assets. Troubleshoot, update, and re-upload the file if needed.

  6. Click Import to import the finalized asset list to the target location. This may take several seconds or more, depending on the number of rows you have in your CSV file.

Upon import, the assets will appear in the hierarchy under the specified racks.

Adding a single asset

  1. Go to Assets → Add New.

  2. Select the intended asset type from the Type dropdown. Fields relevant to that asset type will appear. All non-location asset types typically prompt for values for:

    • Name
    • Manufacturer
    • Model
    • Location
    • Serial Number
    • Asset Tag (optional)
    • Sensor Monitoring Profile (defaults to “Discovered”)
  3. Enter values as appropriate. Depending on your inputs further values may be required.

    • If you are creating a rackable asset, you will need to specify the exact rack location.
    • If you selected “BACnet/IP” as the Sensor Monitoring Profile, you will need to provide Definition, IP Address, Port (defaults to 47808), Device Instance, Network Number (optional), Hardware Address (optional), Hardware Address Length (optional), and Data Collector values.
    • If you selected “Modbus TCP” as the Sensor Monitoring Profile, you will need to provide Definition, IP Address, Port (defaults to 502), Slave Address, and Data Collector values.
  4. Do either of the following:

    • Click Add → Add and Continue With New Values to start with blank fields for subsequent entries; or
    • Click Add → Add and Continue With Same Values to repeat the entered values (except for Name) for subsequent entries.

monitoring_22

The asset will now appear in the hierarchy (Assets → Overview → click “Hierarchy” in the drop-down) under its parent location.

You can also create an asset from the right-click menu in the hierarchy (right-click on parent location → Add New Asset). Note that with this approach you can click on Add to simply add the asset, in addition to being able to add and continue with new or same values (as described in step 4 above).

Tip

Create a Data Collector before attempting to add an asset with a BACnet/IP or Modbus TCP sensor monitoring profile (see Adding discoveries). You can update an existing asset’s monitoring details from Information → Monitoring.

Moving an asset to a Rack Elevation

You can move an asset to a rack (provided there is enough free space).

  1. Navigate to the rack layout view where the Rack Elevation is displayed.
  2. Locate the device in the hierarchy tree.
  3. Drag the device from the hierarchy tree into a rack unit in the Rack Elevation.

Adding discoveries

Hyperview’s Discovery feature (generally referred to “discovery” in Hyperview documentation) auto-detects and registers device assets. This includes servers, routers, rack PDUs, and other ping-able devices that are connected to your network. In addition, discoveries populate metadata, such as manufacturer-created device images, and updates existing device records.

Adding a Data Collector

Once you have installed a Data Collector (note: refer to Planning and setup), you will need to add it in Hyperview.

  1. Go to Discoveries → Data Collectors → Add Data Collector.
  2. Follow the instructions and click Save.

Once the Data Collector is added it will appear in the Data Collectors table.

Adding and configuring a discovery

  1. Go to Discoveries → Overview → Add.
  2. Enter details and click Create.

The new discovery will appear in the Overview table. Note that discoveries are set to monitor newly-discovered assets by default. To configure the discovery, click Details.

add_discovery_2

  • Use the Basic Settings tab to update discovery details.
  • Use the IP Address tab to enter device IP address to include or exclude for the discovery.
  • Use the Protocol Settings dropdown to toggle or update various protocol-specific settings.
  • Use the Schedules tab to set the discovery run frequency.

Running a discovery

  1. Go to Discoveries → Overview.
  2. Click Run Now for the intended discovery.

add_discovery_4

The discovery will start running. Once it has run, a discovery report will be generated. Additionally, the discovery’s Details page will show a brief status.

Viewing a discovery report

  1. Go to Discoveries → Overview.
  2. Click Details for the intended discovery.
  3. Click Discovery Report.